Register    Login    Forum    Search    FAQ

Board index » MotioninJoy install and config » Windows 64bits system




Post new topic Reply to topic  [ 14 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Analog doesn't work/controller works but not detected on DS3
 Post Posted: Tue Jul 20, 2010 11:29 am 
Offline
user

Joined: Tue Jul 20, 2010 11:23 am
Posts: 3
1. Analog problem
The analog sticks on my Sixaxis PS3 controller doesn't work. I kept clicking on the modes in DS3 to Analog Gamepad, but they keep going back to Digital Gamepad all the time.
Please tell me what is wrong.

2. Detection problem
Everytime I go on DS3, it shows "No game controller!" on the Connected game controller(s) option. When I go on the site to where the settings are, it says the same darn thing!
The weird thing is that it works perfectly (except the analog sticks) on my emulator, and other games. What is the problem?


Top 
 Profile  
 
Sponsor
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Tue Jul 20, 2010 4:43 pm 
Offline
MotioninJoy Developer

Joined: Mon Jul 27, 2009 11:29 pm
Posts: 710
Check out your device manager of windows.
Make sure there are not errors in human interface device list.


Attachments:
humsnintfacedevice.png
humsnintfacedevice.png [ 11.64 KiB | Viewed 19253 times ]

_________________
Recommended ImageBluetooth 2.1+EDR Adapter for MotioninJoy
Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Tue Jul 20, 2010 9:59 pm 
Offline
user

Joined: Tue Jul 20, 2010 11:23 am
Posts: 3
Acxie wrote:
Check out your device manager of windows.
Make sure there are not errors in human interface device list.


There is no problems, but the internet (and DS3 tool) doesn't detect the device.

BTW, there are some games that can use the main face buttons, but not the d-pad. Weird.


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Tue Jul 20, 2010 10:06 pm 
Offline
user

Joined: Tue Jul 20, 2010 11:23 am
Posts: 3
Nevermind, the update fixed the detection, and the analog works perfectly.


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Wed Jul 21, 2010 12:01 am 
Offline
MotioninJoy Guru
User avatar

Joined: Fri May 14, 2010 4:20 am
Posts: 1264
PS3Problems101 wrote:
1. Analog problem
The analog sticks on my Sixaxis PS3 controller doesn't work. I kept clicking on the modes in DS3 to Analog Gamepad, but they keep going back to Digital Gamepad all the time.
Please tell me what is wrong.

2. Detection problem
Everytime I go on DS3, it shows "No game controller!" on the Connected game controller(s) option. When I go on the site to where the settings are, it says the same darn thing!
The weird thing is that it works perfectly (except the analog sticks) on my emulator, and other games. What is the problem?


1. The DS3 Tool does that after a reboot or closing it, not much you can do about it right now.
2. Close then reopen the DS3 Tool (make sure to close it out of the system tray too).

_________________
< Install the MotioninJoy Drivers | MiJ: FAQ | Compatibility | Install Local mode | :arrow: More >


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Sun Aug 01, 2010 5:23 pm 
Offline
user

Joined: Sun Aug 01, 2010 5:19 pm
Posts: 3
I am having this exact same problem. Updating the software did not fix the issue either, nor has exiting / re-opening the DS3 tool, which I've done many times now. I have uninstalled ALL usb drives and re-installed repeatedly, and that includes right-clicking on Install USB Driver in the MiJ start menu folder and running as admin. I've clicked on "Enable" in the DS3 tool, as well as used the Driver Manager tool to "load" several times.

Like what was stated in the OP, my PS3 controller (connected via USB) works with all buttons except the analog joysticks, and the quick config page of the DS3 tool reads, "No Game Controller!"

The last time I used MiJ, my analogs were working just fine, but that was several months ago, which was apparently before this update. Is there any permanent and concrete fix to this?


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Sun Aug 01, 2010 9:43 pm 
Offline
MotioninJoy Guru
User avatar

Joined: Fri May 14, 2010 4:20 am
Posts: 1264
Make sure you disabled driver signature enforcement.

_________________
< Install the MotioninJoy Drivers | MiJ: FAQ | Compatibility | Install Local mode | :arrow: More >


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Tue Aug 03, 2010 5:36 pm 
Offline
user

Joined: Sun Aug 01, 2010 5:19 pm
Posts: 3
I have disabled that. I have "Test Mode Build 7600" showing in the bottom right corner of my desktop, and I've had the computer set like that for months now, ever since I first installed MiJ. Like I said I had this working fine a few months ago, but ever since I tried using it this week and, as a result, downloaded the newest version of MiJ, I cannot get the analogs to function anymore. I feel at this point that this is a bug with the new version. I don't see what else I could possibly do.


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Wed Aug 04, 2010 11:20 pm 
Offline
MotioninJoy Guru
User avatar

Joined: Fri May 14, 2010 4:20 am
Posts: 1264
So you went the Test mode / Sign the driver method of disabling driver signature enforcement.... You must re-sign the drivers after a driver update to get it to work again.

_________________
< Install the MotioninJoy Drivers | MiJ: FAQ | Compatibility | Install Local mode | :arrow: More >


Top 
 Profile  
 
 Post subject: Re: Analog doesn't work/controller works but not detected on
 Post Posted: Wed Aug 18, 2010 9:32 am 
Offline
user

Joined: Sun Aug 01, 2010 5:19 pm
Posts: 3
xtr_desert wrote:
So you went the Test mode / Sign the driver method of disabling driver signature enforcement.... You must re-sign the drivers after a driver update to get it to work again.


I'm sorry, I'm not sure how to do that. I'm somewhat of a computer noob when it comes to configuring drivers in this way. What steps are necessary to install this driver properly then? As I understand it, I was supposed to disable driver signature enforcement. I googled that to figure out the steps to do that, and that's what produced the test mode.

By the way, thank you for the quick replies.


Top 
 Profile  
 
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 14 posts ]  Go to page 1, 2  Next

Board index » MotioninJoy install and config » Windows 64bits system


Who is online

Users browsing this forum: Bing [Bot], Google Adsense [Bot] and 14 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: